The issue affecting the accessibility of our brand website, along with some impacted services, has now been resolved. Our Engineering Team will continue to closely monitor the situation to ensure ongoing stability.
We appreciate your patience and understanding while we worked to address this matter. Please be assured that we will continue to provide updates should any new developments arise.
Posted May 18, 2026 - 21:33 AEST
Identified
We have identified another issue affecting the accessibility of our brand website, as well as some impacted services, and our Engineering Team is working around the clock to resolve it.
Please know that we are doing everything we can to address this matter, and we will provide timely updates as soon as more information becomes available.
Posted May 18, 2026 - 16:33 AEST
Monitoring
The issue affecting the accessibility of our brand website, along with some impacted services, has now been resolved. Our Engineering Team will continue to closely monitor the situation to ensure ongoing stability.
We appreciate your patience and understanding while we worked to address this matter. Please be assured that we will continue to provide updates should any new developments arise.
Posted May 18, 2026 - 14:48 AEST
Identified
We are aware of the issue affecting the accessibility of our brand website, as well as some impacted services, and our Engineering Team is working around the clock to resolve it.
Please know that we are doing everything we can to address this matter, and we will provide timely updates as soon as more information becomes available.
Posted May 18, 2026 - 14:08 AEST
This incident affects: Web Hosting Plesk, Reseller Hosting Plesk, Web Hosting cPanel, Reseller Hosting cPanel, VMWare VPS, and Dedicated Servers.