Service Alert: Web24 Phone Lines Currently Down
Incident Report for Web24
Resolved
Web24 phone issues are resolved now.
Posted Jun 11, 2024 - 15:22 AEST
Update
We are continuing to work on a fix for this issue.
Posted Jun 11, 2024 - 12:54 AEST
Identified
We are currently experiencing issues with our phonelines. We are working on resolving this as soon as possible. In the meantime please call us on
03 9988 1903.
Posted Jun 11, 2024 - 12:47 AEST
This incident affected: Web Hosting Plesk, Reseller Hosting Plesk, Web Hosting cPanel, and Reseller Hosting cPanel.