Web24 1300 Number
Incident Report for Web24
Resolved
We have resolved the issue with our 1300 number.
Posted 7 months ago. Feb 14, 2018 - 11:24 AEDT
Investigating
We are currently experiencing issue with our 1300 number and are working with our vendor to resolve it. Please use the 03 9988 1903 number to get in touch with our team or submit a ticket.

Apologies for any inconvenience.
Posted 7 months ago. Feb 14, 2018 - 10:53 AEDT