Web24 Phone System
Incident Report for Web24
Resolved
Our systems administrators have resolved the phone system issue.

Apologies for any inconvenience caused.
Posted 5 months ago. Apr 17, 2018 - 10:55 AEST
Investigating
Our systems administrators are currently troubleshooting an infrastructure issue which has caused our phone system to go offline.

For support requests please create a ticket through your Web24 control panel or send an email to support@web24.com.au from your registered email address.

Please subscribe to this incident to receive an SMS or Email notification when our phone support is operational.
Posted 5 months ago. Apr 17, 2018 - 09:18 AEST