Inbound Phone Call Issue
Incident Report for Web24
Resolved
This incident has been resolved.
Posted 12 days ago. Aug 06, 2018 - 11:25 AEST
Investigating
We are currently investigating an issue affecting inbound phone calls. The phone system is erroneously reporting that it is outside of business-hours. We will provide an update shortly.
Posted 12 days ago. Aug 06, 2018 - 10:54 AEST
This incident affected: Technical Support (Phone).