Support Ticket System Issues
Incident Report for Web24
Resolved
Our support ticket system is currently fully functional
Posted 23 days ago. Sep 26, 2019 - 07:59 AEST
Investigating
Our support ticket system is currently experiencing issues which are impacting customer replies and new support tickets.
We are investigating these issues and will provide an update once more information is available.

Please call us at 1300 493 224 if you need any assistance, our support phone line is fully functional.
Posted 23 days ago. Sep 26, 2019 - 04:12 AEST
This incident affected: Technical Support (Tickets).