Phone service interruption
Incident Report for Web24
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 03, 2018 - 13:19 AEST
Update
All phone services have now been restored.
Posted 5 months ago. Jul 03, 2018 - 13:18 AEST
Investigating
At Web24 we pride ourselves in providing a very high level of service so it is with great disappointment that we need to inform you that we are experiencing interruptions with our phone system. We apologise for any inconvenience this may be causing you.

Our team of System Engineers are urgently investigating the issue and we will update you on our progress as soon as we possibly can.

You can always contact us by submitting a ticket: https://www.web24.com.au/submit-support-ticket/
Posted 5 months ago. Jul 03, 2018 - 13:16 AEST
This incident affected: Technical Support (Phone).