Web24 Phone System
Incident Report for Web24
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 23, 2018 - 15:01 AEDT
Investigating
We have identified a network issue currently affecting our phone system and are working with urgency to resolve the issue.
Posted 5 months ago. Feb 23, 2018 - 14:55 AEDT