Hazard Notification: Issues with email delivery
Incident Report for Web24
Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 10:23 AEST
Monitoring
Please be advised that we have been alerted to an issue with email delivery for some hosts that reside on our address space.

Please see the following link for details:

https://help.web24.com.au/en/knowledgebase/article/outgoing-mail-rejected-by-uceprotect-level-3-faqs-w24

We are closely monitoring this situation, and taking the appropriate action for any service that violates our terms and conditions.
Posted Jun 08, 2021 - 08:00 AEST
This incident affected: Dedicated Servers and Email Filtering Cluster.